First 3 days of December cost data missing from the Cost Management Overview dashboard
Incident Report for Virtana
Postmortem

This issue stemmed from one primary and one secondary cause.

The primary cause was that the workflows, both nightly and backfill, had been modified to use a feature built into Airflow for waiting a specified time before progressing the workflow. That mechanism appeared to be basing its start time at the beginning of the workflow rather than after the previous task. Thus, we switched back to using a prior mechanism of time.sleep in a wait task. This reversion was incomplete, though, and did not include the trigger rule allowing it to always run when all prior tasks were complete, regardless of their final disposition.

The secondary issue that we addressed first involves a mechanism of deployment.

This has been fixed. Further investigation as to why we had failures, and notifying upon failure, and addressing the deployment issue, is under way but does not impact this incident.

Posted Dec 06, 2023 - 16:17 UTC

Resolved
This issue is now resolved. All data for December should now be loaded and nightly processing has been returned to its normal functionality.
Posted Dec 06, 2023 - 16:13 UTC
Investigating
We are currently investigating the issue.
Posted Dec 05, 2023 - 16:06 UTC
Identified
There was an issue with data processing of cloud costs data. One fix was applied but the issue persists. Investigation is ongoing.

The impact is that the Cost Management dashboard is missing data for the first four days of December.

The issue is currently being investigated by engineering.
Posted Dec 04, 2023 - 19:56 UTC
This incident affected: Data Processing.