Delays Loading Azure Data
Incident Report for Virtana
Postmortem

On Wednesday, June 14th at 15:30 UTC there were reports of performance degradation within the Cost Saving Opportunities summary widgets and the Bill Analysis report. The team confirmed the reports were slow to load and producing error messages due to cloud provider API connectivity issues. Investigation into the connectivity issues is ongoing. In the meantime, improvements have been made to better handle scenarios where cloud provider APIs are unreachable or in a degraded performance state. We apologize for any disruptions this issue may have caused.

Posted Jun 16, 2023 - 16:43 UTC

Resolved
This incident has been resolved.

Our platform could not reliably communicate with customer cloud provider accounts for a brief period of time. The team is further investigating why there were connectivity issues, and they working on ways to better handle when the cloud provider APIs are not responsive.

A postmortem with more details will be shared within a business day.
Posted Jun 14, 2023 - 19:11 UTC
Update
The team is still looking into the issue. Root cause has not been identified yet.
Posted Jun 14, 2023 - 17:30 UTC
Update
Users with Azure integrations may notice slow loading or loading failures for Cost Saving Opportunities summary widgets and the Bill Analysis report. Our team continues working towards a prompt resolution.
Posted Jun 14, 2023 - 16:44 UTC
Investigating
Some users are experiencing problems loading the Cost Saving Opportunities and Bill Analysis pages.
The issue appears to be limited to Azure datasets. Our team is currently working towards a prompt resolution.
Posted Jun 14, 2023 - 16:05 UTC
This incident affected: Data Access.