Right Sizing and Cost vs. utilization Reports not showing data for Azure customers
Incident Report for Virtana
Postmortem

Our team discovered a failure in Optimize Right Sizing and Cost vs. Utilization reports not displaying for Azure customers. The root cause was lack of support of a new PublisherType filter option recently introduced in the Azure API. 

A code change was done to support this new filter option. Subsequent jobs were re-triggered and this reporting capability has been fully restored. There was no data loss associated with this outage.

We apologize for any inconveniences this incident may have caused.

Posted Mar 30, 2022 - 21:12 UTC

Resolved
This incident has been resolved.
Posted Mar 30, 2022 - 01:15 UTC
Monitoring
Fix has been deployed to production. Jobs kicked off, we are monitoring.
Posted Mar 29, 2022 - 23:12 UTC
Update
Fix has been verified in our test environment and is being deployed to production. Backfill jobs will need to run but Azure Right Sizing and Cost vs Utilization data should begin appearing within the hour.
Posted Mar 29, 2022 - 22:14 UTC
Update
We continue to work on pushing the fix for this issue into prod.
Posted Mar 29, 2022 - 20:34 UTC
Identified
We have identified the issue and in the process of fixing it.
Posted Mar 29, 2022 - 19:24 UTC
Update
We are continuing to investigate the issue.
Posted Mar 29, 2022 - 18:59 UTC
Investigating
We are currently investigating this issue. No data is shown for Right Sizing and Cost vs. utilization Reports for Azure integrations.
Posted Mar 29, 2022 - 18:20 UTC
This incident affected: App-UK (EU) (Data Processing) and App-US (US) (Data Processing).