500 Error Attempting to Run Migrate Cost Analysis
Incident Report for Virtana
Postmortem

An issue was introduced in our platform where the Migrate Move Group Cost Analysis function would encounter the following error: "Error Code: 500 Message: Move group creation has failed. The uploaded file does not include any VMs from the VM info file. Please verify and load again."

This issue was caused by a hardware failure in our cloud provider's infrastructure. It was resolved by a restart of the physical host and the applications residing on it. We plan to discuss ways we can improve failover mechanisms that will better protect us against these failures.

We apologize for any inconveniences this incident may have caused.

Posted Feb 17, 2022 - 17:23 UTC

Resolved
This incident has been resolved. We've confirmed cost analysis is working without error and as expected.

A postmortem with additional details will be provided within 24 hours.
Posted Feb 17, 2022 - 04:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2022 - 04:32 UTC
Identified
The issue has been identified and we are planning to begin implementing a fix in 30 minutes at 8:30 PM PST.
Posted Feb 17, 2022 - 04:02 UTC
Update
We are continuing to work towards a resolution and will provide timely updates as soon as one is available
Posted Feb 17, 2022 - 00:12 UTC
Update
We have identified the root cause and have started working towards a solution
Posted Feb 16, 2022 - 23:30 UTC
Update
We are continuing to investigate this issue
Posted Feb 16, 2022 - 22:59 UTC
Update
We are continuing to investigate this issue
Posted Feb 16, 2022 - 22:29 UTC
Update
We are continuing to investigate this issue
Posted Feb 16, 2022 - 21:58 UTC
Update
We are continuing to investigate this issue.
Posted Feb 16, 2022 - 21:58 UTC
Update
We are continuing to investigate this issue
Posted Feb 16, 2022 - 21:27 UTC
Update
We are continuing to investigate this issue
Posted Feb 16, 2022 - 20:50 UTC
Update
We are continuing to investigate this issue
Posted Feb 16, 2022 - 20:20 UTC
Investigating
We are currently investigating an issue preventing users from running cost analysis in Migrate.

Users may see a 500 error returned in the UI when attempting to run it.

Further updates will be provided as necessary.
Posted Feb 16, 2022 - 19:34 UTC
This incident affected: App-UK (EU) (Data Processing) and App-US (US) (Data Processing).