Optimize > Cost Vs Utilization Report not loading
Incident Report for Virtana
Postmortem

On 2021-10-18 at 10:52 AM EST our Team identified an issue with the Cost Vs Utilization Report not loading for certain Optimize Customers. Engineering determined the issue was due to a change on a filter that triggered rate-limiting by Cloud Providers for some specific customer accounts. By preventing the affected accounts to continue making attempts to the Cloud Providers API and reverting that change we quickly recovered.
Our Team will work with the Cloud Providers on strategies to avoid these kind of incidents in the future and improve our application code for better performance

Posted Oct 19, 2021 - 17:55 UTC

Resolved
This incident has been resolved.

A summary of the issue and resolution will be provided within a business day.
Posted Oct 18, 2021 - 17:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
We have determined only some users are impacted by this issue.
Posted Oct 18, 2021 - 17:24 UTC
Update
Our engineers continue to work to mitigate this problem. We will provide another update in the next 30 minutes.
Posted Oct 18, 2021 - 16:58 UTC
Update
We are continuing to work to restore service and expect to implement a fix shortly
Posted Oct 18, 2021 - 16:22 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 18, 2021 - 15:52 UTC
Identified
The issue has been identified and our Engineering Team is actively working towards a resolution for this matter.
Posted Oct 18, 2021 - 15:22 UTC
Investigating
We are currently investigating this issue.
Optimize > Cost Vs Utilization Report not loading.
Customers will see the spinning circle on the Cost Vs Utilization Report and the page won't load
Posted Oct 18, 2021 - 14:52 UTC
This incident affected: App-US (US) (Data Access).